skip to Main Content

cisco switch minimum konfigürasyon

bu örnekte cisconun 3700 serisi switchlerde temel konfigürasyonun nasıl yapılacağına bakacağız.

ağ topolojimizi planlarken ağımızda hangi vlanların kullanılacağını belirlediğimi varsayıyoruz. temel olarak ağ yapılandırmasında  grupları yönetim, data  ve voip olarak ayrılmasında fayda vardır.  

ağımızda 10 ve 20 data ve 30 ses için vlanlarını kullanacağımızı düşünerek gerekli vlan tanımlamalarını yapalım. cisco switch kullandığımızdan  ve ağımızın çok büyük olmayacağınızı düşünerek stp olarak pvst kullanalım.

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,10,20,30 priority 4096

vlan internal allocation policy ascending
!
vlan 10
name DATA
!
vlan 20
name DATA2
!
vlan 30
name VOIP

vlanlarımızı tanımladıktan sonra uplink için gerekli konfigürasyonumuzu girebiliriz.  bu örnekte switchimizde uplink portunu gi 1/0/1 olarak kullanacağız. port modunu trunk  ve encapsulation dot1q olarak tanımlayacağız.  eğer bu switchi dış dünyaya açılan noktanız da kullanacaksanız servis sağlayıcınızdan kullanmanız vlan bilgisini temin etmeniz gerekmektedir.

interface GigabitEthernet1/0/1
description *** uplink ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,20,30
switchport mode trunk

uplink tanımında dikkat edilmesi gereken iki nokta daha var. bunlardan bir tanesi auto negoation ve mtu değeridir. benim kullanmakta olduğum switch üzerinde 4 adet ge port mevcut. herhangi bir uplink koruması ve yedeklemesi yapmayacağımız için ilave bir konfigürasyon yapmamıza gerek yok. diğer üç port için konfigürasyon girmiyoruz. konfigürasyon dosyasında aşağıdaki şekilde görmemiz gerekmekte.

interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4

şimdi switchimiz için gerekli ip yapılandırmasını yapalım. elimizdeki bilgiler

default vlan : 1
ip : 10.1.1.10/24

şeklinde ise

ip subnet-zero
ip routing

interface Vlan1
ip address 10.1.1.10 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server

şimdi kullanacağımız fast ethernet portları içinde gerekli konfigürasyon tanımı yaparsak switchimiz kullanıma hazır hale gelecek. geriye switch erişimi v.b. konularda gerekli konfigürasyonlar kalacaktır. ağımızda kullanılacak voip telefonlarda ve pclerde sadece bir ethernet port var her kullanıcıya iki ethernet port verilmesi gerekmekte. bunun için switchimizin yarısını data yarısını ses için ayırıyoruz.

interface FastEthernet1/0/1
description *** A-data ***
switchport access vlan 10
switchport mode access

interface FastEthernet1/0/2
description *** A-voip ***
switchport access vlan 20
switchport mode access

bu tanımı her port için ayrı ayrı giriyoruz. switch kullanıma hazır. burada ses için gerekli vlan kısmını kullanmayarak bu switch metro ethernet hattımızda sonlandırma switchi olarak kullanabiliriz.

cisco 7925 factory reset

Step 1 Choose SETTINGS > Phone Settings.
Step 2 Press **2 on the keypad.
The phone briefly displays “œStart factory reset now?”
Step 3 Press the Yes softkey. All settings are deleted and the phone cycles through normal startup procedures.
Or press No to cancel the reset.
Step 4 Press SETTINGS > Network Profiles to reconfigure the network settings for your WLAN.

Metro Ethernet

Gelişen teknoloji   – genişband ve kesintisiz hizmet ihtiyacı kullanıcıları Metro Ethernet hizmetine yönelmektedir.  Küçük işletmeler ve uzak uç ofisler için g.shdsl, tdm v.b. çözüm olsa da Metro Ethernet in sunduğu faydalar ve kullanım kolaylıkları ile göz ardı edilememektedir. Bu yüzden her geçen gün Metro Ethernet müşterilerinin sayısı artmaktadır.

Şu anda bu hizmeti alabileceğimiz hizmet veren kurum sayısı maalesef bir elin parmaklarının sayısı kadar.

Alt yapı konusunda hala lider konumda olan Türk Telekom veya Global İletişim ilk tercih edilenler arasında. Global İletişim gerek tesis gerekse aylık ücret konusunda müşteri kazanmak ““ pazardan pay kapmak için müşterilere daha cazip teklifler sunabilse de Türk Telekom daki hizmet kalitesini kimi zaman bulmakta zorluk çekebiliyorsunuz. Bunun en önemli nedeni Global ve benzeri servis sağlayıcılarının devrelerinin noktadan noktaya olması ve kendi uç noktaları üzerinden internete çıkartıyor olması.

Bir müşteri  ( gerçek kişilerin şu anki fiyatlarla alması için çok çok fazla kazancının olması lazım ) Metro Ethernet bağlantısına sahip olmak istediğinde talebini bu servis sağlayıcılarından birine talebini belirtmek zorunda. ( bu şirketler ellerindeki tüm verileri analiz ederek müşteri portföylerini siz bunu istemeden büyük olasılıkla sizi ziyaret etmedilerse bile etmeleri yakındır )

Bu hizmetini alınabilmesi için, Metro Ethernet hizmeti alabileceğiniz en yakın hizmet noktasından hizmet almak istediğiniz noktaya kadar fiber optik kablo çekilmesi gereklidir. Hizmeti alabileceğiniz mesafe size ne kadar yakınsa o kadar şanslısınız demektir. Çünkü bu mesafeye göre size bir bağlantı ücreti çıkacaktır. 3 ““ 5 km lik bir mesafede çıkabilecek bağlantı ücreti birçok küçük ““ orta düzey şirket / kurum için bu hizmeti almaktan vazgeçmelerine neden olabilecek düzeyde çıkabilir.  Belirli bir yıl hizmet satın alma taahhüdü ile bazı avantajlardan faydalanılabilmektedir.

Bilgi işlem salonunuza kadar fiber optik kablo çekildi ise size bir adet fiber uç sonlandırma özelliğine sahip bir switch, router v.b. aktif cihaz gerekecektir.

Bu aktif cihazı adsl kampanyalarında olduğu gibi mevcut hizmeti belirli bir süre kullanacağınızı taahhüt ederseniz servis sağlayıcılarınızdan temin edebilirsiniz.

Piyasa da birçok ürün bulunmakta. Her üründe olduğu gibi kopya cihazlardan uzak durmanızda fayda var. Yoksa ileride başınıza olmadık işler açılabilir.

Otoriteler tarafından da onaylandığı üzere bu işin piri Cisco. Ancak yüksek fiyatları nedeniyle alternatiflerine yönelebiliriz. Alcatel, tellabs,  huawei v.b. Telekom alanında donanım üreten birçok firmanın işinize yarayacak mutlaka bir ürünü vardır.

Gerekli donanımı seçmeden önce ihtiyaçlarınızı iyi belirlemelisiniz. Aksi takdirde bilişim yatırım kalemleriniz artacaktır.

Orta ölçekli kurumlar için en önemli kriterler arasında

L2 ““ L3 tercihi
Port Sayısı  – FE ve GE destekleri
Kullanılacak servis destekleri

Önemli özellikler arasında.

Birden fazla statik ip ye ihtiyacınız var ve/veya farklı sunucularınız mevcut   ise L3 bir switch almanız gerekecektir.

Cisco için en fazla bilinen 3650, 3750 işiniz fazlasıyla görecektir.

3650 üzerinde 2 adet 1Gbps GE ve 24 adet 10/100 Mbps FE port mevcuttur.  3650 için basit bir yapılandırma yapalım.

GE portunu trunk olarak tanımlayalım, kapsülleme olarak dot1q  seçelim ve auto negotiate ayarlarınız yapalım. Temel bir tanım olduğu için vlan kısıtlaması v.b. bir şey yapmayacağız

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

şimdi servis sağlayıcımız tarafından verilen vlan ve ip bloklarını tanımlayalım ve gerekli yönlendirme tablosunu ekleyelim.

interface Vlan100
ip address x.x.x.x 255.255.255.252
ip route 0.0.0.0 0.0.0.0 x.x.x.x-1

switchimiz için gerekli ip ve gateway bilgilerini girdik. Şimdi ekstra bir ip bloğu daha aldıysak bunun gerekli vlan bilgisini tanımlayalım.

interface Vlan50
ip address   y.y.y.y 255.255.255.248

şimdide hangi portalara bu vlanları kullanacağımızı belirleyelim”¦

interface FastEthernet0/xx (xx port numarası)
switchport access vlan 50
switchport mode Access

şimdide diğer portlarımız için gerekli tanımları yapalım.

interface FastEthernet0/yy (yy port numarası)
switchport mode access

Temel olarak switchimizi konfigürasyonu artık hazırdır.

Cisco – Telnet mi, SSH mi?

SSH varken güvenliğe önem verken hiç kimse telnet kullanmayı tercih etmez… Bunun için Cisco swith router ımızda eğer ssh desteği varsa

!
line vty 0 X
transport input ssh
!

yaparak sadece ssh e izin verebiliriz. Burada X catalyst 3750 için 15 olacak. Diğer modeller için kullanma kılavızuna bakmakta fayda var…

Back To Top