skip to Main Content

huawei ağda cisco ip telefon ve cdp kullanımı

ağınızda huawei switchler kullanıyor ve cisco ip telefon bağladığınız durumlarda cisco telefonun sdp keşif protokolünü kullanmasından dolayı ağ topoloji oluşturmakta sorunlar yaşanabilir.

bu gibi durumlarda huawei switch üzerinde cdp protokolünü aktif etmeniz gerekmetedir. huawei switch zerine ip telefon bağlanma durumuna karşı temel konfigürasyonu adım adım yapalım.

öncelikle ses (voice) için kullanacağımız vlanı oluşturalım.

<fcicek_test_switch>system-view
[fcicek_test_switch] vlan 2
[fcicek_test_switch-vlan2] quit

vlan 2 yi ses vlanı olarak aktif edelim.

[fcicek_test_switch] voice vlan 2 enable

globalde lldp ve cdp yi aktif edelim

[fcicek_test_switch] lldp enable
[fcicek_test_switch] lldp compliance cdp

şimdi sıra ip telefon bağlayacağımız portların konfigürasyonu yapmaya sıra geldi. öncelikle arayüz içine girerek voice vlan aktif edelim

[fcicek_test_switch] interface GigabitEthernet 2/0/1
[fcicek_test_switch-GigabitEthernet2/0/1] voice vlan enable

sıra lldp ve cdp ayalarını yapmaya geldi

[fcicek_test_switch-GigabitEthernet2/0/1] lldp enable
[fcicek_test_switch-GigabitEthernet2/0/1] lldp admin-status txrx
[fcicek_test_switch-GigabitEthernet2/0/1] lldp compliance admin-status cdp txrx

artık arayüzümüz üzerindeki cisco ip telefonu keşfedebiliriz. bu minimum konfigürasyonu tüm ip telefon kullanacağınız arayüz uygulamakta fayda vardır. şimdi gerekli kontrolleri yapalım.

[fcicek_test_switch] display lldp neighbor-information
CDP neighbor-information of port 97[GigabitEthernet2/0/1]:
  CDP neighbor index : 1
  Chassis ID         : SEP00141CBCCCAA
  Port ID            : Port 1
  Sofrware version   : P0030301MFG2
  Platform           : Cisco IP Phone 7960
  Duplex             : Full

cisco switch minimum konfigürasyon

bu örnekte cisconun 3700 serisi switchlerde temel konfigürasyonun nasıl yapılacağına bakacağız.

ağ topolojimizi planlarken ağımızda hangi vlanların kullanılacağını belirlediğimi varsayıyoruz. temel olarak ağ yapılandırmasında  grupları yönetim, data  ve voip olarak ayrılmasında fayda vardır.  

ağımızda 10 ve 20 data ve 30 ses için vlanlarını kullanacağımızı düşünerek gerekli vlan tanımlamalarını yapalım. cisco switch kullandığımızdan  ve ağımızın çok büyük olmayacağınızı düşünerek stp olarak pvst kullanalım.

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,10,20,30 priority 4096

vlan internal allocation policy ascending
!
vlan 10
name DATA
!
vlan 20
name DATA2
!
vlan 30
name VOIP

vlanlarımızı tanımladıktan sonra uplink için gerekli konfigürasyonumuzu girebiliriz.  bu örnekte switchimizde uplink portunu gi 1/0/1 olarak kullanacağız. port modunu trunk  ve encapsulation dot1q olarak tanımlayacağız.  eğer bu switchi dış dünyaya açılan noktanız da kullanacaksanız servis sağlayıcınızdan kullanmanız vlan bilgisini temin etmeniz gerekmektedir.

interface GigabitEthernet1/0/1
description *** uplink ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,20,30
switchport mode trunk

uplink tanımında dikkat edilmesi gereken iki nokta daha var. bunlardan bir tanesi auto negoation ve mtu değeridir. benim kullanmakta olduğum switch üzerinde 4 adet ge port mevcut. herhangi bir uplink koruması ve yedeklemesi yapmayacağımız için ilave bir konfigürasyon yapmamıza gerek yok. diğer üç port için konfigürasyon girmiyoruz. konfigürasyon dosyasında aşağıdaki şekilde görmemiz gerekmekte.

interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4

şimdi switchimiz için gerekli ip yapılandırmasını yapalım. elimizdeki bilgiler

default vlan : 1
ip : 10.1.1.10/24

şeklinde ise

ip subnet-zero
ip routing

interface Vlan1
ip address 10.1.1.10 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server

şimdi kullanacağımız fast ethernet portları içinde gerekli konfigürasyon tanımı yaparsak switchimiz kullanıma hazır hale gelecek. geriye switch erişimi v.b. konularda gerekli konfigürasyonlar kalacaktır. ağımızda kullanılacak voip telefonlarda ve pclerde sadece bir ethernet port var her kullanıcıya iki ethernet port verilmesi gerekmekte. bunun için switchimizin yarısını data yarısını ses için ayırıyoruz.

interface FastEthernet1/0/1
description *** A-data ***
switchport access vlan 10
switchport mode access

interface FastEthernet1/0/2
description *** A-voip ***
switchport access vlan 20
switchport mode access

bu tanımı her port için ayrı ayrı giriyoruz. switch kullanıma hazır. burada ses için gerekli vlan kısmını kullanmayarak bu switch metro ethernet hattımızda sonlandırma switchi olarak kullanabiliriz.

Back To Top