skip to Main Content

securecrt uygulamasında anahtar kelime vurgulama yaparak ekran görüntüsünü renklendirmek

securecrt uygulamanı bir şekilde kullanıyorsanız uygulamayı daha kullanışlı hale getirmek uygulayacağınız yöntemlerden bir taneside “keyword highlighting” kullanmaktadır..

artık neredeyse tüm ssh client uygulamalarında mevcut olan ve “anahtar kelime vurgulama” olarak çevirilecek bu özellik securecrt ekran çıktılarıda bazı kelimeleri renklendirmenizi sağlamaktadır.

securecrt genel regex desteğini bu özellik içinde sunmaktadır.

şimdi basit örnek yapalım… öncelikle options altında “edit default session” menusu açıyoruz.

açılan aktif oturum ayarlarımız için sol taraftaki menuden “keyword highlighting” i seçiyoruz… burada neim network diye bir liste tanımladığım ve onun altında bazı keywordlar eklediğim görülmektedir. sizde kendinize uygun yeni bir liste oluşturabilirsiniz. veya mevcutta bir liste varsa onun üzerinde güncelleme yapabilirsiniz.

bu örnekte çıktımızda ip bilgilerinin kırmızı olarak renklendirmesini istediğimi düşünelim.

ip bilgisi için doğru regex i yazmalıyız… regex konusunda tecrübeniz yoksa arama motorlarında konu hakkında arama yaparak hazır regexlere ulaşabilirsiniz.

ip için : (?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9]) regexini kullanacağız.

Ekranda “new keyword:” karşısına regex i ekleyelim. bu alana giriş yaptıktan sonra + işeretini kullanılabilir olduğu görülmektedir.

Yazıdğımız idade regex içeriyorsu “regular expression” seçeneğinide seçerek + tuşuna basıyoruz.

+ tuşuna bastıktan sonra yeni ifademizin keyword listesine eklendiğini görebiliriz..listeye eklendikten sonra üzerine çift tıklayarak veya sağ tarafta yer alan genel olarka konfigürasyon veya özellikler anlamına gelen dişli resmine tıklarak tekrardan düzenleme yapabilir veya securecrt in sunduğu ilave özellikler üzerin değiştirebilirsiniz.

şimdi iseyaptığımız değişikliğin işe yarayıp yamadığını görelim…yeni bir oturum açarak google.com adresine ping atalım.. aşagıdaki çıktıda görüleceği üzere artık ip adresleri kırmızı olarak renklendirilmektedir.

nokia sros üzerinde ip filter ile paket inceleme

nokia sros güvenlik yönetimi, müşteri yönetimi gibi amaçlar için filttelerin uygulnamasına izin vermektedir. aynalama yönteminin mümkün olmadığı, debug yapamadığınız zamanlarda filtreme yöntemini kullanmak paket yakalama / analizini temel düzeyde yapmaya olanak sağlayabilir. bunun nasıl yapılacağına en basit haliyle inceleyelim.

öncelikle yazacağımız filtre ile gözlemleyeceğimiz paketlerin nerede tutulması gerektiğe ait ayarları yapmakta fayda var. bu örnekte ramde tutulması bizim için yeterli olacak. log için bir id belirleyerek öncelikle filter log oluşturalım.

*A:#/configure filter log 38 create
*A:>config>filter>log# info 
----------------------------------------------
----------------------------------------------
*A:>config>filter>log#

log ortamımının tutulacağı alanı oluşturmuş olduk. default değeri 1000 olduğu için bu dğeri ihtiyacımız karşılayacak düzeyde arttıralım.

*A:>config>filter>log# destination memory 20000

verilecek değerde dikkatli olunmalı. hafızayı şişirmemek gerekli. şimdi paket yakalamak için filtremizi oluşturabiliriz. yakalamak istediğimiz paketlerin hedef ve kaynak iplerini bildigimizi düşünerek ip bazlı bir filtre yapalım.

filtreleri oluştururken paketler üzerinde bir engelleme v.b. yapmacağımız için default-action ve entry lerin action forward yapmayı unutmuyoruz.

bu örneğimizde epipe bir servisin üzerindeki paket analizini yapacağımız için hem ingress hemde egress e filtre uygulamamız gerkiyor. burada dikkat edilmesi gereken önemli bir nokta var. ingress ve egress lere filtrre uygularken hedef ve kaynak ipleri yer değiştirmiş olacak.. bu nedenden dolayı oluşturduğumuz ip-filter altına iki tane entry ekliyoruz ve ip adreslerini buna göre giriyoruz…

her entry altında yakalanan paketlerin kaydedilmesi için oluşturdugumuz log idsini de ekledikten sonra filtremiz tamamlanmış oluyoruz.

*A:#/configure filter ip-filter 38 create
*A:>config>filter>ip-filter# info 
            default-action forward
            entry 10 create
                match
                    dst-ip x.x.x.x/32
                    src-ip y.y.y.y/32
                exit
                log 38
                action
                    forward
                exit
            exit
            entry 11 create
                match
                    dst-ip y.y.y.y/32
                    src-ip x.x.x.x/32
                exit
                log 38
                action
                    forward
                exit
            exit

daha optimum bir filtre oluşturulabilir ancak bu haliye işimizi görecektir. filtremiz hazır olduğuna göre sıra uygulamaya geldi.

*A:#/configure service epipe 1 
*A:>config>service>epipe# info 
----------------------------------------------
           sap lag-1:1 create
                ingress
                    filter ip 38
                exit
                egress
                    filter ip 38
                exit
                no shutdown
            exit
            spoke-sdp 100:1 create
                no shutdown
            exit
            no shutdown

şimdi paketleri inceleyebiliriz. bakmamız gereken komut ve örnek çıktı aşagıdaki gibidir.

*A:#/show filter log 38

===============================================================================
Filter Log
===============================================================================
Admin state : Enabled
Description : (Not Specified)
Destination : Memory
Wrap        : Enabled
-------------------------------------------------------------------------------
Maximum entries configured : 20000
Number of entries logged   : 116
-------------------------------------------------------------------------------
2022/03/10 20:54:45  Ip Filter: 121:10  Desc: 
SAP: lag-103:115  Direction: Egress  Action: Forward
Src MAC: d4-a1-c8-df-b3-b0  Dst MAC: 02-45-11-12-78-d3  EtherType: 0800
Src IP: x.x.x.x:500  Dst IP: y.y.y.y:500  Flags: 0  TOS: c0  TTL: 254 Len: 196
Protocol: UDP

“Maximum entries configured : 20000” alanında ne kadar log olacağı bilgisi mecut .. biz 20000 yapmıştık… “Number of entries logged : 116” komutu çalıştırdığımızda yazdığımız filtreye giren 116 kayıt olduğunu görüyoruz. alltraki kısımlarda ip nin gözlendiği pakete ait bilgiler yer almaktadır..

log dosyasını temizlemek istediğinizde ise

*A:#/clear filter log 38

komutu kullanılabilir.

linux – ip adresinin öğrenilmesi

linux de bir ethernet arayüzünün ip adresinin ifconfig çıktısından inceleyerek bulabiliriz. ancak nokta atışı yapılması gereken zamanlar olabilir.

aşagıdaki örnekte adım adım incelenebilir.

fcicek@ubuntu:~$ ifconfig eth0 
eth0      Link encap:Ethernet  HWaddr 00:0c:29:68:00:00  
          inet addr:192.168.126.128  Bcast:192.168.126.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe68:0000/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:388668 errors:0 dropped:0 overruns:0 frame:0
          TX packets:226787 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:506708018 (506.7 MB)  TX bytes:22826593 (22.8 MB)
fcicek@ubuntu:~$ ifconfig eth0 | grep 'inet addr:'
          inet addr:192.168.126.128  Bcast:192.168.126.255  Mask:255.255.255.0
fcicek@ubuntu:~$ ifconfig eth0 | grep 'inet addr:' | awk '{print$2}' 
addr:192.168.126.128
fcicek@ubuntu:~$ ifconfig eth0 | grep 'inet addr:' | awk '{print$2}' | cut -d: -f2
192.168.126.128

linuxte iç ve dış ip adresi değişimlerinin twitter hesabına gönderilmesi

dış dünyaya dinamik bir ip adresi ile çıkıyor ve olası ip değişimlerinden haberdar olmak istiyorsanız elbette bunun yapmanın çok fazla yöntemi var.

bu örnekte dhcp tarafından ip değişimlerinin alğılanarak twitter üzerinden gönderilmesi konusunda ufak bir örnek yapacağız.

twitter için yeniden bir yazılım yapmayacağız.. mevcut linux cli uygulamalarını kullanabiliriz. Bu örnekte tuby ile geliştirilen T yi kullancağız. https://github.com/sferik/t adresinden yazlım hakkında gerekli bilgilendirme alınabilir..

ruby nin installer yazılımını yükleyelim ve sonrasında ise T yazılımını yükleyelim.

fcicek@ubuntu:~$ sudo apt-get install ruby-dev
fcicek@ubuntu:~$ gem install t

twitter üzerinden bu işlem için kullanacağımız bir twitter hesabı oluşturalım ve bu hesap ile http://dev.twitter.com/apps/new adresinden yeni bir uygulama oluşturalım.

ve sonrasında uygulama erişim ayarlarını yönergeleri izleyerek yapalım.

fcicek@ubuntu:~$ t authorize
It looks like you ve already registered an application with Twitter.
To authorize a new account, just follow the steps below:
  1. Sign in to the Twitter Developer site.
  2. Select the application for which you d like to authorize an account.
  3. Copy and paste the consumer key and secret below when prompted.

Press [Enter] to open the Twitter Developer site. 

authorize işlemi tamamlandıktan sonra

fcicek@ubuntu:~$ t account

fcicek@ubuntu:~$ t whoami

ile hesap kontrollerini gerçekleştirelim. ve sonrasında test için mesaj gönderelim

fcicek@ubuntu:~$ t dm ferhatcicek test
Direct Message sent from @fcicekcli to @ferhatcicek.

twitterin istemci yazılımı ile ilgili kısımları tamamladıktan sonra en önemli kısıma geldi. dhcp nin olduğu bölümü ögrendikten sonra dhclient.conf konfigürasyon dosyası içinde gerekli düzenlemeleri yapalım.

fcicek@ubuntu:~$ whereis dhcp
dhcp: /etc/dhcp

dhclient.conf dosyası /etc/dhcp/ dizini altında yer almaktadır. konfigürasyon dosyası içerisinde dhclient-script dosyasının aktif edilmesi gerekmektedir. (dizin yapısı ile ilgili sorun olabilir. )

fcicek@ubuntu:/etc/dhcp$ whereis dhclient-script
dhclient-script: /sbin/dhclient-script /usr/share/man/man8/dhclient-script.8.gz

dosyanın doğru yerini ögrendikten sonra dhclient.conf dosyası içinde

fcicek@ubuntu:/etc/dhcp$ vi dhclient.conf 

script "/sbin/dhclient-script";

gerekli düzenlemeyi tamamlayalım ve bir sonraki adıma geçelim.

fcicek@ubuntu:/etc/dhcp$ ls
dhclient.conf  dhclient-enter-hooks.d  dhclient-exit-hooks.d

dhclient-enter-hooks.d dizini içine çalışacak olan scriptimiz yarattığınız zaman olay tamamlanmıştır..

vi tt

PRIVATE_IP=$(ifconfig |grep -B1 "inet addr" |awk '{ if ( $1 == "inet" ) { print $2 } else if ( $2 == "Link" ) { printf "%s:" ,$1 } }' |awk -F: '{ print $1 ": " $3 }')
PUBLIC_IP=$(dig -4 @ns1-1.akamaitech.net -t a whoami.akamai.net +short)

/usr/local/bin/t   dm @ferhatcicek "$PRIVATE_IP \n ip: $PUBLIC_IP"

cisco switch minimum konfigürasyon

bu örnekte cisconun 3700 serisi switchlerde temel konfigürasyonun nasıl yapılacağına bakacağız.

ağ topolojimizi planlarken ağımızda hangi vlanların kullanılacağını belirlediğimi varsayıyoruz. temel olarak ağ yapılandırmasında  grupları yönetim, data  ve voip olarak ayrılmasında fayda vardır.  

ağımızda 10 ve 20 data ve 30 ses için vlanlarını kullanacağımızı düşünerek gerekli vlan tanımlamalarını yapalım. cisco switch kullandığımızdan  ve ağımızın çok büyük olmayacağınızı düşünerek stp olarak pvst kullanalım.

spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,10,20,30 priority 4096

vlan internal allocation policy ascending
!
vlan 10
name DATA
!
vlan 20
name DATA2
!
vlan 30
name VOIP

vlanlarımızı tanımladıktan sonra uplink için gerekli konfigürasyonumuzu girebiliriz.  bu örnekte switchimizde uplink portunu gi 1/0/1 olarak kullanacağız. port modunu trunk  ve encapsulation dot1q olarak tanımlayacağız.  eğer bu switchi dış dünyaya açılan noktanız da kullanacaksanız servis sağlayıcınızdan kullanmanız vlan bilgisini temin etmeniz gerekmektedir.

interface GigabitEthernet1/0/1
description *** uplink ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,20,30
switchport mode trunk

uplink tanımında dikkat edilmesi gereken iki nokta daha var. bunlardan bir tanesi auto negoation ve mtu değeridir. benim kullanmakta olduğum switch üzerinde 4 adet ge port mevcut. herhangi bir uplink koruması ve yedeklemesi yapmayacağımız için ilave bir konfigürasyon yapmamıza gerek yok. diğer üç port için konfigürasyon girmiyoruz. konfigürasyon dosyasında aşağıdaki şekilde görmemiz gerekmekte.

interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4

şimdi switchimiz için gerekli ip yapılandırmasını yapalım. elimizdeki bilgiler

default vlan : 1
ip : 10.1.1.10/24

şeklinde ise

ip subnet-zero
ip routing

interface Vlan1
ip address 10.1.1.10 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server

şimdi kullanacağımız fast ethernet portları içinde gerekli konfigürasyon tanımı yaparsak switchimiz kullanıma hazır hale gelecek. geriye switch erişimi v.b. konularda gerekli konfigürasyonlar kalacaktır. ağımızda kullanılacak voip telefonlarda ve pclerde sadece bir ethernet port var her kullanıcıya iki ethernet port verilmesi gerekmekte. bunun için switchimizin yarısını data yarısını ses için ayırıyoruz.

interface FastEthernet1/0/1
description *** A-data ***
switchport access vlan 10
switchport mode access

interface FastEthernet1/0/2
description *** A-voip ***
switchport access vlan 20
switchport mode access

bu tanımı her port için ayrı ayrı giriyoruz. switch kullanıma hazır. burada ses için gerekli vlan kısmını kullanmayarak bu switch metro ethernet hattımızda sonlandırma switchi olarak kullanabiliriz.

ipv6

ipv6 ya geçişte bir türk deyimi ile se se devri kapandı. artık bundan sonra si si ipv6.

Alcatel 7302 – ip değiştirme

alcatel 7302 isam   için ip değişikliği yapmanız gerekirse sisteme ssh, telnet veya konsol ile bağlantı gerçekleştirdikten sonra mevcut ip bilgisine bakalım.

leg:isadmin># configure system management
leg:isadmin>configure>system>management# info
configure system
#—————————————
echo “system”
#—————————————

management
host-ip-address manual:1.1.1.10/24
default-route 1.1.1.254
exit
exit
#—————————————
leg:isadmin>configure>system>management#

yukarıda 7302 üzerine girilmiş   bilgiler görülmektedir.. Şimdi kendi alt yapımıza uygun olarak konfigüre edelim. Ancak sistemde tanımlı bir default route olduğu için ip değiştirme komutunu verdiğimizde hata verecektir. Bunun için öncelikle default route değerini kaldıralım.

leg:isadmin># no configure system management default-route

Sisteme yeni ip ve default route degeri girilebilir.

leg:isadmin># configure system management host-ip-address manual:10.10.10.42/24
leg:isadmin># configure system management default-route 10.10.10.254

Back To Top