Skip to content

windowsda statik yönlendirme

tercih veya benim gibi zorunluluktan windows kullanıyor olabilirsiniz. ihtiyaç halinde windows da statik yönlendirme nasıl yapılacağı sorulmuştu…

statik yönlendirme komut formatı aşagıdaki şekilde.

route ADD destination_network MASK subnet_mask  gateway_ip metric_cost IF interface_id

bu işlem için statik yönlendirme yapma yetkisine sahip bir kullanıcı olmalısınız. kişisel bir bilgisayar kullanıyırsanız powershell veya cmd yi yöneticisi yetkisi ile çalıştır demeniz yeterli olacaktır.

örnek bir komut yazacak olursak

route add 10.38.0.0 mask 255.255.255.0 192.168.0.1

ile 10.38.0.0/24 adresini 192.168.0.1 ipsine yönlendirmiş oluyoruz. windows üzerinde vpn bağlantısı, sanal makine v.b. kullanıyor ve yönlendirmeyi bunlara yapmak istiyorsanız interface id yi ögrenmemiz gerekmektedir. bunun için

route print interface

komutu ile interface listesini alabiliriz.

===========================================================================
Interface List
 18...02 05 85 7f eb 80 ......Juniper Networks Virtual Adapter
  8...38 64 58 b1 a9 60 ......Intel(R) Ethernet Connection (13) I219-LM
  6...0c 9a 3a f7 33 c2 ......Microsoft Wi-Fi Direct Virtual Adapter
 20...0e 9a 3a f7 33 c1 ......Microsoft Wi-Fi Direct Virtual Adapter #2
  7...0c 9a 3a f7 33 c1 ......Intel(R) Wi-Fi 6 AX201 160MHz
  1...........................Software Loopback Interface 1
===========================================================================

şimdi listede yer alan juniper arayüzüne dogru statik bir yönlendirme örneği yazalım.

route add 10.38.0.0 mask 255.255.255.0 172.16.0.1 IF 18

huawei – iki switch arasi statik route

elimizde s5700 serisi iki adet huawei switch olduğunu düşünelim. switchlerimizi aşağıdaki topolojiye uygun olarak fiziksel bağlantılarını gerçekleştirelim.

 

basit_switch_ornek1

fiziksel bağlantıların doğru olup olmadığını “diplay interface brief” ile kontrol edebilirsiniz. bu komutun çıktısı aşağıdakine benzer olacaktır. her iki switchde gerekli bağlantıları kontrol ettikten sonra en temel tanımlamalarımızı yapmaya başlayalım.

bu örnekte ofis_a ve ofis_b switchine gerekli tanımlamaları eş zamanlı girildiği belirtmekte fayda var.

InUti/OutUti: input utility/output utility
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors
GigabitEthernet0/0/1        up    up          0%     0%          0          0
GigabitEthernet0/0/2        up    up          0%     0%          0          0
GigabitEthernet0/0/3        down  down        0%     0%          0          0
GigabitEthernet0/0/4        down  down        0%     0%          0          0
GigabitEthernet0/0/5        down  down        0%     0%          0          0

cihazlarımızı karıştırmamak için öncelikle cihazlarımıza birer ad verelim. bunun için “sysname sistem_adi” komutu kullanılacaktır.

system-view 
Enter system view, return user view with Ctrl+Z.	
[Huawei]sysname ofis_b
[ofis_b]

switch yönetimi ve 10.0.0.1/24 için 100 vlanı kullanacağız. ofis_b switch için gerekli tanımlamaları adım adım girelim.

vlan 100 i switch üzerine ekleyerek ip adresini ekleyelim

[ofis_b]vlan batch 100
[ofis_b]interface Vlanif 100
[ofis_b-Vlanif100]ip address 10.0.0.2 24
[ofis_b-Vlanif100]display this
#
interface Vlanif100
 ip address 10.0.0.2 255.255.255.0
#
return
[ofis_b-Vlanif100]quit

şimdi gerekli statik route u yazalım.

[ofis_b]ip route-static 0.0.0.0 0.0.0.0 10.0.0.1

route için gerekli kontrolleri yapalım..

[ofis_b]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 1
The number of interface that is DOWN in Protocol is 3

Interface                         IP Address/Mask      Physical   Protocol  
MEth0/0/1                         unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Vlanif1                           unassigned           up         down      
Vlanif100                         10.0.0.2/24          down       down  
   

yukarıda 100 vlanın eklendiğini ve 10.0.0.2/24 in fiziksel ve protokol olarak down olduğu görülmekte. yani sıra fiziksel arayüz tanımlamaları yapmaya geldi demek.

[ofis_b]nterface GigabitEthernet 0/0/1
[ofis_b-GigabitEthernet0/0/1]description ofis_a—ofis_b
[ofis_b-GigabitEthernet0/0/1]port link-type trunk
[ofis_b-GigabitEthernet0/0/1]port trunk allow-pass 100
[ofis_b-GigabitEthernet0/0/1]quit


0/0/1 portunu trunk mode olarak ayarladık ve 100 vlanı bu porta tanımladık. şimdi gerekli kontrolleri yapalım.


[ofis_b]display ip interface brief 
*down: administratively down
^down: standby
(l): loopback
(s): spoofing
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 2
The number of interface that is UP in Protocol is 1
The number of interface that is DOWN in Protocol is 3

Interface                         IP Address/Mask      Physical   Protocol  
MEth0/0/1                         unassigned           down       down      
NULL0                             unassigned           up         up(s)     
Vlanif1                           unassigned           up         down      
Vlanif100                         10.0.0.2/24          up         up   
  

buradan görüldüğü üzere 100 vlani fiziksel ve protokol olarak up görülmektedir.

sıra geldi en temel kontrole

[ofis_b-GigabitEthernet0/0/1]ping 10.0.0.1
  PING 10.0.0.1: 56  data bytes, press CTRL_C to break
    Reply from 10.0.0.1: bytes=56 Sequence=1 ttl=255 time=50 ms
    Reply from 10.0.0.1: bytes=56 Sequence=2 ttl=255 time=30 ms
    Reply from 10.0.0.1: bytes=56 Sequence=3 ttl=255 time=50 ms
    Reply from 10.0.0.1: bytes=56 Sequence=4 ttl=255 time=50 ms
    Reply from 10.0.0.1: bytes=56 Sequence=5 ttl=255 time=10 ms

ofis_a swith konfigürasyonu

ofis_b swith konfigürasyonu

Back To Top