skip to Main Content

huawei routerlarda interface üzerinde alarm sayısını sıfırlama

huawei routerlarda display komutu ile interface detaylarına baktığımızda interface üzerinde meydana gelen hatalarıda görebiliyoruz. bu hatalar sürekli artımlı şekilde devam etmektedir.

[fcicek_test_router-GigabitEthernet1/0/0]display interface GigabitEthernet 1/0/0
GigabitEthernet1/0/0 current state : UP
Line protocol current state : DOWN
Link quality grade : GOOD
Description:sube_a
Route Port,The Maximum Transmit Unit is 1500
Internet protocol processing : disabled
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is aaaa-aaaa-aaaa
The Vendor PN is RTXM191-400
The Vendor Name is WTD
Port BW: 1G, Transceiver max BW: 1G, Transceiver Mode: SingleMode
WaveLength: 1310nm, Transmission Distance: 10km
Rx Power: -6.51dBm, Warning range: [-20.00, -3.00]dBm
Tx Power: -5.53dBm, Warning range: [-9.00, -3.00]dBm
Loopback:none, full-duplex mode, negotiation: enable, Pause Flowcontrol:Receive Enable and Send Enable
Last physical up time   : 2016-07-19 09:41:00 UTC+02:00 DST
Last physical down time : 2016-07-19 09:39:46 UTC+02:00 DST
Current system time: 2016-08-13 06:11:06+02:00
Statistics last cleared:never
    Last 10 seconds input rate: 6816 bits/sec, 7 packets/sec
    Last 10 seconds output rate: 5632 bits/sec, 5 packets/sec
    Input: 144440952031 bytes, 928751872 packets
    Output: 335843205389 bytes, 872370561 packets
    Input:
      Unicast: 855698710 packets, Multicast: 53900340 packets
      Broadcast: 19152822 packets, JumboOctets: 12274608 packets
      CRC: 100 packets, Symbol: 0 packets
      Overrun: 0 packets, InRangeLength: 0 packets
      LongPacket: 0 packets, Jabber: 0 packets, Alignment: 0 packets
      Fragment: 0 packets, Undersized Frame: 0 packets
      RxPause: 0 packets
    Output:
      Unicast: 872368829 packets, Multicast: 0 packets
      Broadcast: 1732 packets, JumboOctets: 137186914 packets
      Lost: 0 packets, Overflow: 0 packets, Underrun: 0 packets
      System: 0 packets, Overrun: 0 packets
      TxPause: 0 packets
    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%

eğer bir interfacede hatayı gidermeye yönelik bir işlem yaptıysanız interface üzerindeki hataları sıfırlamak her zaman işimizi kolaylaştıracaktır.

yukarıda örnekte 1/0/0 interfaceinde 100 adet CRC hatası geldiği görülmektedir. bunu sıfırlamak için interface içine konfigürasyon modda girerek port-alarm komutunu kullanıyoruz.

[fcicek_test_router-GigabitEthernet1/0/0]port-alarm clear ?
  crc-error     CRC error alarm
  input-error   Input error alarm
  output-error  Output error alarm
  pause-frame   Pause Frame alarm
  symbol-error  Symbol error alarm

yukarıda görüldüğü gibi bu interface üzerinde 5 adet hatanın değerlerini sıfırlayabiliyoruz.

bizim hatalarımız crc hataları olduğu için crc hatalarının sayısını sıfırlamak için aşagıdaki komutu tamamlamamız gerekecektir

[fcicek_test_router-GigabitEthernet1/0/0]port-alarm clear crc-error

 

huawei cihazlarda yeniden başlatma ( reboot )

bazı özel durumlarda cihazı uzaktan yeniden başlatmanız gerekebilir. bu gibi durumlarda reboot komutu işinize yarayacaktır.

komutu çalıştırdığınızda sistem çalışan konigürasyon ile kayıtlı konigürasyonu karşılaştırarak bir farklılık var ise çalışan konfigürasyonu kayıt edip etmeyeceğini sorar sonrasında ise cihazı yeniden başlatmak için sizden onay isyerek eğer cevap olumlu ise yeniden başlatma işlemi uygulanır.

<fcicek_test_router>reboot
Info: The system is now comparing the configuration, please wait.
Warning: All the configuration will be saved to the next startup configuration.
Continue ? [y/n]:n
System will reboot! Continue ? [y/n]:y
Info: system is rebooting ,please wait...

anlık olarak yeniden başlatma bu şekildedir. ancak yeniden başlama işlemi zamanlanmak isteyebilir. bunu cihazınızın yazılımına bağlı olarak schedule reboot ile gerçekletirebilirsiniz.

<fcicek_test_router> schedule reboot at 01:00 2015/11/30
Info: System will reboot at 01:00:00 2015/11/30 (in 10 hours and 10 minutes)
confirm? [Y/N] :y

huawei ağda cisco ip telefon ve cdp kullanımı

ağınızda huawei switchler kullanıyor ve cisco ip telefon bağladığınız durumlarda cisco telefonun sdp keşif protokolünü kullanmasından dolayı ağ topoloji oluşturmakta sorunlar yaşanabilir.

bu gibi durumlarda huawei switch üzerinde cdp protokolünü aktif etmeniz gerekmetedir. huawei switch zerine ip telefon bağlanma durumuna karşı temel konfigürasyonu adım adım yapalım.

öncelikle ses (voice) için kullanacağımız vlanı oluşturalım.

<fcicek_test_switch>system-view
[fcicek_test_switch] vlan 2
[fcicek_test_switch-vlan2] quit

vlan 2 yi ses vlanı olarak aktif edelim.

[fcicek_test_switch] voice vlan 2 enable

globalde lldp ve cdp yi aktif edelim

[fcicek_test_switch] lldp enable
[fcicek_test_switch] lldp compliance cdp

şimdi sıra ip telefon bağlayacağımız portların konfigürasyonu yapmaya sıra geldi. öncelikle arayüz içine girerek voice vlan aktif edelim

[fcicek_test_switch] interface GigabitEthernet 2/0/1
[fcicek_test_switch-GigabitEthernet2/0/1] voice vlan enable

sıra lldp ve cdp ayalarını yapmaya geldi

[fcicek_test_switch-GigabitEthernet2/0/1] lldp enable
[fcicek_test_switch-GigabitEthernet2/0/1] lldp admin-status txrx
[fcicek_test_switch-GigabitEthernet2/0/1] lldp compliance admin-status cdp txrx

artık arayüzümüz üzerindeki cisco ip telefonu keşfedebiliriz. bu minimum konfigürasyonu tüm ip telefon kullanacağınız arayüz uygulamakta fayda vardır. şimdi gerekli kontrolleri yapalım.

[fcicek_test_switch] display lldp neighbor-information
CDP neighbor-information of port 97[GigabitEthernet2/0/1]:
  CDP neighbor index : 1
  Chassis ID         : SEP00141CBCCCAA
  Port ID            : Port 1
  Sofrware version   : P0030301MFG2
  Platform           : Cisco IP Phone 7960
  Duplex             : Full

huawei cihaz bilgisi ve seri numarası ögrenilmesi

kullanmakta olduğunuz switchin /routerin özellikle garanti vb. süreçlerinde model numarası ve seri numarası sıklıkla ihtiyaç duyulan şeylerdir.

cihazın model numrası hakkında bilgi almak istersek “display device” işimize yarayacaktır..

[fcicek_test_switch]display device
S5300-28X-LI-24S-DC's Device status:
Slot Sub  Type                Online    Power      Register     Status   Role
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
0    -    S5300-28X-LI-24S    Present   PowerOn    Registered   Normal   Master

eğer seri numarasına ihtiyaç duyarsanız manufacture-info parametresini de ekleyerek bu bilgiye erişebilirsiniz.

[fcicek_test_switch]display device manufacture-info
Slot  Sub  Serial-number          Manu-date
- - - - - - - - - - - - - - - - - - - - - -
0     -    47043AA33770EA000787   2014-10-24

networkünüzde birden fazla cihaz var yönetim için huawei u2000 yazılımı kullanıyorsanız, yönetimsel olarak u2000 eklediğiniz cihazlara ait detaylı bilgileri
u2000_inventory_phy1
menüsünden alabilirsiniz.

huawei switchler için yönetimsel erişim ayarları – 1

huawei switchlerde yönetimsel olarak ayrı bir subnet altında toplanması ve diğer kullanıcı erişimlerinide soyutlayabilmek için kullanılacak en temel yöntemlerden bir tanesi :

erişim için bir vlan belirleyerek bu vlan altına ip bilgisinin girilmesi ve globalde bu ipye ilişkin statik route yazmak şeklinde olacaktır.

yapacağımız işlem kısaca

[fcicek_test] vlan batch 10
[fcicek_test] interface Vlanif10
[fcicek_test-vlanif10] ip address 10.10.10.10 255.255.255.254
[fcicek_test] ip route-static 0.0.0.0 0.0.0.0 10.10.10.9

şeklindedir. cihaz üzerinde erişim için gerekli olarak protokolleri 10 vlanına göre yapılandırmayı unutmamak gerekiyor.

huawei routerlarda multicast yayının route tablosu

huawei cihazlarda multicast yayının route tablosunu görmek için display multicast routing-table komutu kullanılabilir. buradaki “Upstream Interface” multicast yayının yapıldığı uplink port “downstream interface” ise cihaz üzerinde bu yayını alan interfacelerdir. downstream interfacelerde 100 vlanın multicast yayını için kullanıldığı görülmektedir.

[test_router]display multicast routing-table
Multicast routing table of VPN-Instance: public net 
 Total 6 entries

 00001. (10.10.24.122, 239.254.0.4)
       Uptime: 03:00:27
       Upstream Interface: GigabitEthernet2/0/0
       List of 1 downstream interface
           1:  GigabitEthernet2/1/14.100

 00002. (10.10.24.26, 239.254.0.23)
       Uptime: 04:39:58
       Upstream Interface: GigabitEthernet2/0/0
       List of 1 downstream interface
           1:  GigabitEthernet1/0/18.100

 00003. (10.10.24.170, 239.254.0.40)
       Uptime: 05:50:40
       Upstream Interface: GigabitEthernet2/0/0
       List of 1 downstream interface
           1:  GigabitEthernet2/1/14.100

 00004. (10.10.24.12, 239.254.0.42)
       Uptime: 00:19:45
       Upstream Interface: GigabitEthernet2/0/0
       List of 1 downstream interface
           1:  GigabitEthernet1/0/1.100
                                          
 00005. (10.10.24.19, 239.254.0.84)
       Uptime: 01:40:39
       Upstream Interface: GigabitEthernet2/0/0
       List of 1 downstream interface
           1:  GigabitEthernet2/1/12.100

 00006. (10.10.8.85, 239.254.0.144)
       Uptime: 1d:09h
       Upstream Interface: GigabitEthernet2/0/0
       List of 5 downstream interfaces
           1:  GigabitEthernet2/1/12.100
           2:  GigabitEthernet2/1/14.100
           3:  GigabitEthernet3/0/5.100
           4:  GigabitEthernet3/0/14.100
           5:  GigabitEthernet3/0/0.100

huawei – aktif alarmların listelenmesi ve silinmesi

huawei cihazlarda cli üzerinden alarm yönetimi yapmak zorunda olduğunuz durumlar olabilir. bu örnekte ne40 serisi cihazlar üzerinden alarm yönetimi değilde daha çok mevcut alarmların listelenmesi ve bu alarmların silinmesine değineceğim. bunu ihtiyaç duyma nedenimiz huawei cihazları üzerindeki bazı yazılımsal sorunlar nedeniyle gerçekte bir sorun olmamasına karşın alarm bilgisinin silinmemesi ve/veya konfigürasyonun buna göre yapılmış olmasındadır.

“display alarm” kotumu cli üzerinden alarm izlemede kullanacağımız temel komuttur.

[huawe_ne40e]display  alarm all
----------------------------------------------------------------------------
Index  Level      Date      Time                        Info

1      Critical   15-05-07  13:04:31    The air filter is failed, Maybe it is 
                                        not cleaned as scheduled. Please clean
                                         it and run the reset dustproof run-ti
                                        me command[OID:1.3.6.1.4.1.2011.5.25.1
                                        29.2.1.9,BasCode:67995]
2      Error      15-03-09  12:53:37    LPU 1 is failed, Low Rx Pow ALM of SFP
                                        7 ALARM of PIC0 is abnormal[OID:1.3.6.
                                        1.4.1.2011.5.25.129.2.1.9,BasCode:67697]
----------------------------------------------------------------------------

yukarıdaki şekilde önceliklendirilmiş tüm alamları görebiliriz. bu listedeki alarmları temizlemek için clear komutu kullanılır ancak dikkat edilmesi gereken nokta konfigürasyon modunda olmamaktadır.

#huawe_ne40e>clear alarm index 2 send-trap 
Confirm to delete. continue?[Y/N]:Y
Info: Succeed in deleting the current alarm!

yukarı komut ile listelenen 2 numaralı alarm silinmiştir. send-trap komutu kullanılarak eğer bir nms kullanıyorsanız onuda tetiklemekte ve nms programında da alarm silinmektedir.

işin biraz daha ayrıntısına girecek olursak “display alarm active” ile cihaz üzerindeki tüm aktif alarmları görebiliriz.”display logbuffer” a kaydedilen verilerin kaynağı burasıdır diyebiliriz. yine “display alarm all” ile listenenen alarmlar burada yer almaktadır.

[huawe_ne40e]display  alarm active 
A/B/C/D/E/F/G/H/I/J
A=Sequence, B=RootKindFlag(Independent|RootCause|nonRootCause)
C=Generating time, D=Clearing time
E=ID, F=Name, G=Level, H=State
I=Description information for locating(Para info, Reason info)
J=RootCause alarm sequence(Only for nonRootCause alarm)

  36679/Independent/2015-02-25 15:45:38+02:00/-/0x701b2000/hwPimNeighborLoss/Major/Start/OID 1.3.6.1.4.1.2011.5.25.149.4.0.1 PIM neighbor loss. (NbrIntIndex=6, NbrAddrType=1, NbrAddr=127.0.0.1, NbrUpTime=1335409100, NbrIntName=GigabitEthernet2/0/0, InstanceID=0, InstanceName=public net, NeighborLossReason=1)
  36681/Independent/2015-02-25 17:02:51+02:00/-/0x502001/linkDown/Critical/Start/OID 1.3.6.1.6.3.1.1.5.3 Interface 6 turned into DOWN state.(AdminStatus=2,OperStatus=2,InterfaceName=GigabitEthernet2/0/0)
  39018/Independent/2015-03-09 12:53:41+02:00/-/0xff142808/hwEntityInvalid/Critical/Start/ OID 1.3.6.1.4.1.2011.5.25.129.2.1.9 Physical entity failed. (EntityPhysicalIndex=16843016, BaseTrapSeverity=2, BaseTrapProbableCause=67697, BaseTrapEventType=5, EntPhysicalContainedIn=16843008, EntPhysicalName="GigabitEthernet1/0/7", RelativeResource="", ReasonDescription="LPU 1 is failed, Low Rx Pow ALM of SFP7 ALARM of PIC0 is abnormal")

sistem her alarm için bir id üretmektedir ve listede en başta yer almaktadır. alarmları clear ederken bu sıra numarasını kullanmak zorundayız.

konfigürasyon modu açık iken “alarm” ile alarm yönetim konsulunu aktif etmemiz gerekmektedir. komutun temel kullanım yapısı aşağıdaki şekildedir.


[huawe_ne40e]alarm
[huawe_ne40e-alarm]clear alarm active sequence-number 36679

istisna durumlar hariç alarm kaynağına neden olan sorun düzeldikten sonra bu listeden otomatik olarak çıkarılacağını unutmamak gerekir.

huawei cihazlarda default konfigürasyon

huawei cihazlarda cli da “display this” komutu ile bulunduğunuz dizindeki mevcut konfigürasyonu görebilirsiniz. ancak default olarak yapılandırılmış konfigürasyon mevcuttur. bunu görmek için display this” komutuna include-default parametresi ilave edilerek kullanılabilir.

aşağıdaki örnekte bir interfacedeki default konfigürasyon görülmektedir.

[ferhatcicek-Ethernet0/0/1]display this include-default 
#
interface Ethernet0/0/1
 portswitch
 undo shutdown
 enable snmp trap updown
 undo set flow-stat interval
 undo qinq vlan-translation enable
 undo mac-address learning disable
 port priority 0
 port link-type hybrid
 port hybrid pvid vlan 1
 port hybrid untagged vlan 1
 qinq protocol 8100
 undo loopback-detect enable
 stp enable
 undo stp config-digest-snoop
 undo stp no-agreement-check
 undo stp root-protection
 undo stp loop-protection
 stp transmit-limit 147
 stp point-to-point auto
 stp compliance auto
 stp instance 0 port priority 128
 undo port mux-vlan enable
 undo mac-vlan enable
 undo ip-subnet-vlan enable
 undo rmon-statistics
 undo smart-link flush receive
 undo smart-link vll-notify enable
 undo ntdp enable
 undo ndp enable
 bpdu enable
 undo portal local-server enable
 undo dot1x enable
 dot1x max-user 256
 dot1x port-control auto
 dot1x port-method mac
 undo dot1x reauthenticate
 undo authentication critical eapol-success
 authentication max-reauth-req 20
 undo mac-authen
 mac-authen max-user 256
 mac-authen reauthenticate
 undo authentication open
 undo port-auto-sleep enable
 undo port-security enable
 undo qinq vlan-translation miss-drop
 undo port discard tagged-packet
 mac-learning priority 0
 undo mac-address flapping trigger error-down
 undo mac-address flapping trigger quit-vlan
 jumboframe enable 9216
 undo set flow-statistics include-interframe
 trap-threshold input-rate 100 resume-rate 100
 trap-threshold output-rate 100 resume-rate 100
 log-threshold input-rate 100 resume-rate 100
 log-threshold output-rate 100 resume-rate 100
 trap-threshold error-statistics 3 interval 10
 carrier up-hold-time 2000
 carrier down-hold-time 0
 undo port link-flap protection enable
 qos wrr
 qos queue 0 wrr weight 1
 qos queue 1 wrr weight 1
 qos queue 2 wrr weight 1
 qos queue 3 wrr weight 1
 qos queue 4 wrr weight 1
 qos queue 5 wrr weight 1
 qos queue 6 wrr weight 1
 qos queue 7 wrr weight 1
 trust 8021p outer
 undo dei enable
 qos phb marking enable
 undo arp anti-attack rate-limit enable
 undo arp-miss anti-attack rate-limit enable
 undo arp anti-attack check user-bind enable
 undo ip source check user-bind enable
 unicast-suppression 100
 multicast-suppression 100
 broadcast-suppression 100
 storm-control interval 5
 port type nni
 undo nd snooping enable
 undo nd snooping trusted
 undo dhcpv6 remote-id insert enable
 undo dhcpv6 remote-id rebuild enable

huawei switchlerde timeout süresi ayarı

bir switch – router üzerinde konfigürasyon ile uğraşırken araya giren başka işler nedeniyle konfigürasyon işleminiz yarım kalır oturumumuz timeout olur.

huawei switch routerlarda konsol bağlantısı için bu sürenin nasıl konfigüre edileceğini konsol ayarları ile birlikte değiştirelim

cihaz üzerine erişim kontrolü user-interface altında yapılmaktadır.

system-view 
Enter system view, return user view with Ctrl+Z.

[Huawei]user-interface ?
  INTEGER<0,34-48,50-54>   The first user terminal interface to be configured
  console                  Primary user terminal interface
  current                  The current user terminal interface
  maximum-vty              The maximum number of VTY users, the default value is 5
  vty                      The virtual user terminal interface 

[Huawei]user-interface console 0

konsol erişimi için bağlantı modu belirleyelim ve bağlantı sırasında girilecek şifremizi belirleyelim.

[Huawei-ui-console0]authentication-mode password 

[Huawei-ui-console0]set authentication password ?
  cipher  Set the password with cipher text
  simple  Set the password in plain text
	
[Huawei-ui-console0]set authentication password simple huawei

şimdi sırada konsol bağlantımızın timeout süresini ayarlamaya geldi. fabrika ayarlarında bu süre 10 dakikadır. bunu 20 dakika olarak ayarlayalım.

[Huawei-ui-console0]idle-timeout ?
  INTEGER<0-35791>  Set the number of minutes before a terminal user times
                    out(default: 10minutes)

[Huawei-ui-console0]idle-timeout 20 ?
  INTEGER<0-59>  Set the number of seconds before a terminal user times
                 out(default: 0s)
             

[Huawei-ui-console0]idle-timeout 20 0

Back To Top