skip to Main Content

apache web server üzerinde kullanıcı dizin yapısını aktifleştirmek

Linux üzerinde Apache kullanıyor ve Linux üzerindeki kullanıcılarınıza bir alan açmak istiyorsanız bu işlem için en kolay yöntem userdir eklentisini aktifleştirmek olacaktır. Bunun ne kadar güvenli ve yönetilebilir olduğu tartışılır ancak en kolay yöntem olduğu kesin.

Gerekli modüllerin ve araçların yüklü olduğundan emin olunmalıdır. Aşağıdaki örnek debian tabanlı bir dağıtım da uygulanmıştır. Dağıtımlara göre dizin yapısı vb fark edebilir.

A2enmod ile userdir modülünü aktifleştirelim.

sudo a2enmod userdir

Modül aktifleştirdikten sonra Apache konfigürasyon dosyaları altında userdir modülü ile ilgili konfigürasyon dosyaları oluşturulmuştur. Bu konfigürasyon dosyası içinde gerekli düzenlemeleri yapılması gerekmektedir.

sudo nano /etc/apache2/mods-enabled/userdir.conf

Temel konfigürasyon dosyası aşağıdaki gibidir. Kullanıcıya açılan dizin ve erişim yetkisi ayarları doğru şekilde ayarlanmalıdır. Yoksa başımıza olmadık işler açabilir.


        UserDir public_html
        UserDir disabled root
 
        
		AllowOverride All
		Options MultiViews Indexes SymLinksIfOwnerMatch
		
			# Apache < = 2.2:
		        Order allow,deny
		        Allow from all
 
		        # Apache >= 2.4:
		        #Require all granted
		
		
			# Apache < = 2.2:
		        Order deny,allow
		        Deny from all
 
			# Apache >= 2.4:
			#Require all denied
		
        


Statik bir alan verecekseniz bu kadar yeterlidir. statik alanmı kaldı diyebilirsiniz. kullanıcıların php kullanmalarını istiyorsanız apachenin php modül konfigürasyon dosyasında gerekli düzenlemeyi yapmanız gerekecektir.

sudo nano /etc/apache2/mods-available/php5.conf

güvenlik gereği kullanıcı dizinlerinde server-side uygulamalar engellenmiş durumdadır. yapılması gereken “php_admin_value engine Off” satırını pasif ederek sunucu yeni konfigürasyonu ile başlatmaktır.


    
	SetHandler application/x-httpd-php
    
    
	SetHandler application/x-httpd-php-source
    
    # To re-enable php in user directories comment the following lines
    # (from  to .) Do NOT set it to On as it
    # prevents .htaccess files from disabling it.
    
        
    #        php_admin_value engine Off
        
    


sunucumuzu yeniden başlattıktan sonra mevcut kullanıcılar için public_html dizinini oluşturmayı unutmayalım..

sudo service apache2 restart
mkdir /home/$USER/public_html

huawei cihazlarda default konfigürasyon

huawei cihazlarda cli da “display this” komutu ile bulunduğunuz dizindeki mevcut konfigürasyonu görebilirsiniz. ancak default olarak yapılandırılmış konfigürasyon mevcuttur. bunu görmek için display this” komutuna include-default parametresi ilave edilerek kullanılabilir.

aşağıdaki örnekte bir interfacedeki default konfigürasyon görülmektedir.

[ferhatcicek-Ethernet0/0/1]display this include-default 
#
interface Ethernet0/0/1
 portswitch
 undo shutdown
 enable snmp trap updown
 undo set flow-stat interval
 undo qinq vlan-translation enable
 undo mac-address learning disable
 port priority 0
 port link-type hybrid
 port hybrid pvid vlan 1
 port hybrid untagged vlan 1
 qinq protocol 8100
 undo loopback-detect enable
 stp enable
 undo stp config-digest-snoop
 undo stp no-agreement-check
 undo stp root-protection
 undo stp loop-protection
 stp transmit-limit 147
 stp point-to-point auto
 stp compliance auto
 stp instance 0 port priority 128
 undo port mux-vlan enable
 undo mac-vlan enable
 undo ip-subnet-vlan enable
 undo rmon-statistics
 undo smart-link flush receive
 undo smart-link vll-notify enable
 undo ntdp enable
 undo ndp enable
 bpdu enable
 undo portal local-server enable
 undo dot1x enable
 dot1x max-user 256
 dot1x port-control auto
 dot1x port-method mac
 undo dot1x reauthenticate
 undo authentication critical eapol-success
 authentication max-reauth-req 20
 undo mac-authen
 mac-authen max-user 256
 mac-authen reauthenticate
 undo authentication open
 undo port-auto-sleep enable
 undo port-security enable
 undo qinq vlan-translation miss-drop
 undo port discard tagged-packet
 mac-learning priority 0
 undo mac-address flapping trigger error-down
 undo mac-address flapping trigger quit-vlan
 jumboframe enable 9216
 undo set flow-statistics include-interframe
 trap-threshold input-rate 100 resume-rate 100
 trap-threshold output-rate 100 resume-rate 100
 log-threshold input-rate 100 resume-rate 100
 log-threshold output-rate 100 resume-rate 100
 trap-threshold error-statistics 3 interval 10
 carrier up-hold-time 2000
 carrier down-hold-time 0
 undo port link-flap protection enable
 qos wrr
 qos queue 0 wrr weight 1
 qos queue 1 wrr weight 1
 qos queue 2 wrr weight 1
 qos queue 3 wrr weight 1
 qos queue 4 wrr weight 1
 qos queue 5 wrr weight 1
 qos queue 6 wrr weight 1
 qos queue 7 wrr weight 1
 trust 8021p outer
 undo dei enable
 qos phb marking enable
 undo arp anti-attack rate-limit enable
 undo arp-miss anti-attack rate-limit enable
 undo arp anti-attack check user-bind enable
 undo ip source check user-bind enable
 unicast-suppression 100
 multicast-suppression 100
 broadcast-suppression 100
 storm-control interval 5
 port type nni
 undo nd snooping enable
 undo nd snooping trusted
 undo dhcpv6 remote-id insert enable
 undo dhcpv6 remote-id rebuild enable

huawei 5700 serisi switchlerde lldp konfigürasyonu

lldp config

huawei serisi switchlerde basit lldp konfigürasyonu nasıl yapılır. incelemeye çalışalım.

[switch_a]display lldp local 
Error: Global LLDP is not enabled.

bu bize lldp nin globalde aktif edilmesi gerektiğini söylüyor.

[switch_a]lldp enable 
Info: Global LLDP is enabled successfully.

display lldp local komutunu tekrar çalıştıralım..

[switch_a]display lldp local 

System information
--------------------------------------------------------------------------
Chassis type   :macAddress 
Chassis ID     :4c1f-cc60-60d8
System name    :switch_a
System description  :S5700-28C-HI 
Huawei Versatile Routing Platform Software 
 VRP (R) software,Version 3.30 (S5700 V200R001C00) 
 Copyright (C) 2007 Huawei Technologies Co., Ltd.
System capabilities supported   :bridge  
System capabilities enabled     :bridge  
LLDP Up time   :2014/7/6 20:0:17

MED system information
--------------------------------------------------------------------------
Device class   :Network Connectivity
(MED inventory information of master board)
HardwareRev       :VER B
FirmwareRev       :NA
SoftwareRev       :Version 3.30 V200R001C00
SerialNum         :NA
Manufacturer name :HUAWEI TECH CO., LTD
Model name        :NA
Asset tracking identifier :NA

System configuration
--------------------------------------------------------------------------
LLDP Status                     :enabled             (default is disabled)
LLDP Message Tx Interval        :30                  (default is 30s)     
LLDP Message Tx Hold Multiplier :4                   (default is 4)       
LLDP Refresh Delay              :2                   (default is 2s)      
LLDP Tx Delay                   :2                   (default is 2s)      
LLDP Notification Interval      :5                   (default is 5s)      
LLDP Notification Enable        :enabled             (default is disabled)
Management Address              :

Remote Table Statistics:
--------------------------------------------------------------------------
Remote Table Last Change Time   :0 days, 0 hours, 0 minutes, 0 seconds           

Remote Neighbors Added          :0     
Remote Neighbors Deleted        :0     
Remote Neighbors Dropped        :0     
Remote Neighbors Aged           :0     
Total Neighbors                 :0     

Port information:
--------------------------------------------------------------------------

Interface GigabitEthernet0/0/1:
LLDP Enable Status       :enabled             (default is disabled)
Total Neighbors          :0

Port ID subtype     :interfaceName 
Port ID             :GigabitEthernet0/0/1 
Port description    :

şeklinde devam eden bize bir çıktı verecektir. bundan sonra lldp management adresinin eklenmesi ve uplinke ait port tanımlarının yapılması gerekli. burada temel olarak loopback0 ile aynı yaparız.

[switch_a]lldp management-address 10.10.10.1
Error: The IP Address does not exist.

[switch_a]interface LoopBack0
[switch_a-LoopBack0]ip address 10.10.10.1 255.255.255.255



[switch_a]lldp management-address 10.10.10.1
Info: Setting management address successfully.


[switch_a]interface  GigabitEthernet 0/0/1
[switch_a-GigabitEthernet0/0/1]bpdu enable 
[switch_a-GigabitEthernet0/0/1]q

bundan sonra lldp local komutunu çıktısını incelersek management ip artık yer aldığı görülecektir.

[switch_a]display lldp local 

System information
--------------------------------------------------------------------------
Chassis type   :macAddress 
Chassis ID     :4c1f-cc60-60d8
System name    :switch_a
System description  :S5700-28C-HI 
Huawei Versatile Routing Platform Software 
 VRP (R) software,Version 3.30 (S5700 V200R001C00) 
 Copyright (C) 2007 Huawei Technologies Co., Ltd.
System capabilities supported   :bridge  
System capabilities enabled     :bridge  
LLDP Up time   :2014/7/6 20:0:17

MED system information
--------------------------------------------------------------------------
Device class   :Network Connectivity
(MED inventory information of master board)
HardwareRev       :VER B
FirmwareRev       :NA
SoftwareRev       :Version 3.30 V200R001C00
SerialNum         :NA
Manufacturer name :HUAWEI TECH CO., LTD
Model name        :NA
Asset tracking identifier :NA

System configuration
--------------------------------------------------------------------------
LLDP Status                     :enabled             (default is disabled)
LLDP Message Tx Interval        :30                  (default is 30s)     
LLDP Message Tx Hold Multiplier :4                   (default is 4)       
LLDP Refresh Delay              :2                   (default is 2s)      
LLDP Tx Delay                   :2                   (default is 2s)      
LLDP Notification Interval      :5                   (default is 5s)      
LLDP Notification Enable        :enabled             (default is disabled)
Management Address              :IP: 10.10.10.1  

Remote Table Statistics:
--------------------------------------------------------------------------
Remote Table Last Change Time   :0 days, 0 hours, 0 minutes, 0 seconds           

Remote Neighbors Added          :0     
Remote Neighbors Deleted        :0     
Remote Neighbors Dropped        :0     
Remote Neighbors Aged           :0     
Total Neighbors                 :0     

Port information:
--------------------------------------------------------------------------

lokal kısım ile ilgili yapacaklarımız bitti. uzak uç ile ilgili bilgilere bakalım.. bunun için lldp neighbor komutunu kullanıyoruz. aşagıdaki çıktıdan görüldüğü üzere interfacelerde herhangi bir cihaz alğılanmamış durumda.

[switch_a]display lldp neighbor 
GigabitEthernet0/0/1 has 0 neighbors

GigabitEthernet0/0/2 has 0 neighbors

GigabitEthernet0/0/3 has 0 neighbors

GigabitEthernet0/0/4 has 0 neighbors

GigabitEthernet0/0/5 has 0 neighbors

uç cihaz konfigürasyonlarınıda yaptıktan sonra tekrar bakacak olursak interface karşı uca ati bilgilerin geldiği görülecektir.

[switch_a]display lldp neighbor 
GigabitEthernet0/0/1 has 1 neighbors:


Neighbor index : 1
Chassis type   :macAddress 
Chassis ID     :4c1f-cccc-3a18 
Port ID type   :interfaceName 
Port ID        :GigabitEthernet0/0/1
Port description    :NA
System name         :switch_b
System description  :S5700-28C-HI 
Huawei Versatile Routing Platform Software 
 VRP (R) software,Version 3.30 (S5700 V200R001C00) 
 Copyright (C) 2007 Huawei Technologies Co., Ltd.
System capabilities supported   :bridge 
System capabilities enabled     :bridge 
Management address type  :ipV4
Management address       : 20.10.10.1  
Expired time   :112s


Port VLAN ID(PVID)  :1
VLAN name of VLAN  1: VLAN1
Protocol identity   :STP STP LACP EthOAM CFM 

Auto-negotiation supported    :No 
Auto-negotiation enabled      :No
OperMau   :speed(0)/duplex(Half)

Power port class         :PD 
PSE power supported      :No 
PSE power enabled        :No 
PSE pairs control ability:No 
Power pairs              :Unknown 
Port power classification:Unknown

Link aggregation supported:Yes 
Link aggregation enabled :No 
Aggregation port ID      :0 
Maximum frame Size       :9216

EEE support              :No 
Transmit Tw              :0 
Receive Tw               :0 
Fallback Receive Tw      :0 
Echo Transmit Tw         :0 
Echo Receive Tw          :0

MED Device information             
Device class   :Network Connectivity

HardwareRev       :VER B
FirmwareRev       :NA
SoftwareRev       :Version 3.30 V200R001C00
SerialNum         :NA
Manufacturer name :HUAWEI TECH CO., LTD
Model name        :NA
Asset tracking identifier :NA

Media policy type   :Voice 
Unknown Policy      :Defined 
VLAN tagged         :Yes 
Media policy VlanID      :0 
Media policy L2 priority :5 
Media policy Dscp        :46

Power Type               :Unknown 
PoE PSE power source     :Unknown 
Port PSE Priority        :Unknown 
Port Available power value:2
GigabitEthernet0/0/2 has 0 neighbors

GigabitEthernet0/0/3 has 0 neighbors

GigabitEthernet0/0/4 has 0 neighbors

GigabitEthernet0/0/5 has 0 neighbors

huawei quidway ekipmanlarında arayüz konfigürasyonun temizlenmesi

cli üzerinden tanımlama  yapanların en sinir olduğu konulardan birisidir kullanılması gereken arayüzler de  geçmişte yapılan tanımların  kırıntıların kalması ve bunların temizlenmesidir. kimi üreticilerin bu gibi durumlarda çözümleri olmasa da huawei firmasının quidway serisi gibi cihazların üzerindeki os lar buna izin verebilmekte..

quidway serisi cihazlarda bunun için cli da clear komutunu kullanıyoruz. genel kullanımı aşağıdaki gibi. komutu girdikten sonra bizden konfigürasyonu silip portu kapatılması yönünde onay alınacak.

[quidway-test] clear configuration interface gigabitethernet 1/1/1
Warning: All configurations of the interface will be cleared, and its state will be shutdown. Continue? [Y/N]: Y

gerekli onay işlemini verdikten sonra bize aşagıdaki şekilde bir bilgi satırı gelecektir. interface içine girerek mevcut konfigürasyonuna baktığımızda konfigürasyonun silindiğini ve interface in kapatıldığını görürüz.

Info: Total execute 7 command (s), 7 successful, 0 failed. "“ this will prompt a total removal of 7 configuration interface

[quidway-test] interface gigabitethernet 1/1/1
[quidway-test-GigabitEthernet1/1/1] display this
#
interface GigabitEthernet1/1/1
shutdown
Back To Top